Barracuda Email Encryption Services experiencing intermittent issues
Incident Report for EMPIST
Resolved
Barracuda resolved the issue and all systems have returned to full operational status. We continued to monitor as well and are now setting this outage to resolved.
Posted 3 months ago. Apr 04, 2019 - 20:35 CDT
Monitoring
Barracuda identified intermittent issues with their email encryption services earlier today. They have a fix and are currently implementing / testing it. We will continue to monitor on our end and provide an update as soon as there is one available.

Here is the link to Barracuda's official incident update from their status page: https://status.barracuda.com/
Posted 3 months ago. Apr 04, 2019 - 15:06 CDT