Hosted Exchange Performance Degraded
Incident Report for EMPIST
Resolved
After monitoring mail flow over the past few hours without an additional incident, we are setting this outage to resolved.
Posted Sep 25, 2017 - 16:16 CDT
Monitoring
We identified an issue at our datacenter that was impacting mail flow for some Hosted Exchange Users. We have since addressed the issues and performance has returned to normal but we will continue monitoring for the next two hours.
Posted Sep 25, 2017 - 13:29 CDT