Issue delivering email to Office 365
Incident Report for EMPIST
Resolved
There have been no further issues. We are closing this Incident at this time.
Posted May 07, 2021 - 18:28 CDT
Update
We are continuing to monitor for any further issues.
Posted May 07, 2021 - 18:28 CDT
Update
We are continuing to monitor for any further issues.
Posted May 07, 2021 - 15:37 CDT
Monitoring
Mail flow has been restored and the queues are flushing. All email should be delivered within the next hour.
Posted May 07, 2021 - 15:37 CDT
Identified
We are experiencing issues delivering email to Office 365. We are working with Microsoft to resolve the problem. All of the email being sent will be delivered when the issue is resolved.
Posted May 07, 2021 - 15:15 CDT
This incident affected: Hosted Spam & Virus Filtering.