Microsoft MFA is having intermittent issues
Incident Report for EMPIST
Resolved
The ability to login to MS Authenticator has been resolved. Operations have returned to normal. We are marking this as resolved, but will continue to keep an eye on it and advise if anything changes.
Posted Nov 19, 2018 - 16:23 CST
Monitoring
New update from Microsoft: "Engineers have deployed the hotfix which eliminated a connection between Azure Identity Multi-Factor Authentication Service and a backend service. The deployment of this Hotfix took some time to take effect across the impacted regions. Engineers are continuing to monitor for a reduction in user authentication errors as a result of this hotfix. Engineers are exploring additional workstreams to fully mitigate this issue."

We will continue monitoring and provide updates as we receive them.
Posted Nov 19, 2018 - 09:45 CST
Identified
There is a known issue at Microsoft intermittently impacting clients accessing MS Services (e.g. O365) using Microsoft authenticator (MFA). There is no ETA at the time. This is the most current update from Microsoft: "Engineers have explored mitigating a back-end service via deploying a code hotfix, and this is currently being validated in a staging environment to verify before potential roll-out to production. Engineers are also continuing to explore additional workstreams to expedite mitigation."

While this is not directly impacting any of EMPIST's services, we did want to put a status update on our status page for any clients who may be using O365 or other MS Cloud Services with MFA turned on.
Posted Nov 19, 2018 - 09:40 CST