Microsoft 365 Email being sent to Junk Mail
Incident Report for EMPIST
Resolved
Microsoft did not provide a further update confirming final resolution, but per our monitoring, the issue appears to be fully resolved. We will continue to check Microsofts incident feed and advise if anything changes. Certainly, contact our support immediately if you suspect the issue is persisting. After changes administered by Microsoft, it's always suggested to close applications and restart them if you detect any lingering issues.
Posted May 27, 2021 - 07:13 CDT
Monitoring
The issue has been identified and the emails are being reprocessed. This is currently being monitored. The following are the two recent updates on the M365 account in Twitter:

"We’re continuing to monitor as the remaining messages are being reprocessed. We’ll provide an estimated timeline as soon as one is available. Additional info is available via the admin center under EX258373."

"The majority of emails should now be reprocessed however, the remaining emails may take some time to complete. We’ll provide the next update within the next hour. Additional info is available via the admin center under EX258373."
Posted May 26, 2021 - 21:29 CDT
Investigating
Microsoft is investigating an issue where email is being sent to the Junk Folder. You can track updates via their Twitter Account at https://twitter.com/MSFT365Status.
Posted May 26, 2021 - 17:18 CDT
This incident affected: Hosted Exchange.