Barracuda Public Cloud experiencing performance issues
Incident Report for EMPIST
Resolved
We continued monitoring this through to resolution. All systems are performing optimally as expected.
Posted Jul 29, 2022 - 12:18 CDT
Update
Services continue returning to full performance. We are removing the degraded performance status for Barracuda's Cloud S&V Services. We will check in again at 20:30.
Posted Jul 28, 2022 - 19:04 CDT
Update
Barracuda services continue to return to normal. It appears as though their Cloud S&V services are amongst the services returning to normal. We will continue monitoring this and provide another update at 18:30.
Posted Jul 28, 2022 - 17:20 CDT
Monitoring
We have identified an issue with Barracuda's Cloud Platform. The following is a link to the most current status updates from Barracuda's status page - https://status.barracuda.com/. Services are being restored but this is still affecting some of our customers, specifically in that they cannot access quarantine pages. We will continue monitoring this incident until all services have been confirmed as restored. Next update at 17:00.
Posted Jul 28, 2022 - 15:50 CDT
This incident affected: Hosted Spam & Virus Filtering.