Incoming Email Delays
Incident Report for EMPIST
Resolved
We are still investigating the root cause, but do know that the issue was caused by a network issue between (2) of our datacenters that caused latency for our Hosted Exchange Servers. No other services were impacted. We monitored email flow throughout the day and there were no other issues. If any other details related to the outage are uncovered, we will provide them here.
Posted Jun 26, 2017 - 18:26 CDT
Monitoring
Email is now flowing properly. We are still investigating the Reason For the Outage (RFO) and will provide more information as soon as we have it. For now, we will continue monitoring for the next 2 hours before setting the issue to resolved.
Posted Jun 26, 2017 - 11:41 CDT
Investigating
We are investigating issues that are causing delays on incoming emails for Hosted Exchange Users. The delays appear to only be impacting incoming emails and is intermittent across all users. We will post an update here when we have identified the source of the delay.
Posted Jun 26, 2017 - 10:41 CDT