Delayed email delivery
Incident Report for EMPIST
Resolved
Our Spam & Virus Service has remained stable and so we closing this incident.
Posted May 06, 2022 - 08:14 CDT
Update
All services have restored to normal performance. Our team continues to monitor the mail flow.
Posted May 05, 2022 - 19:09 CDT
Update
Our team is continuing to monitor the queues. All email is being delivered but with a delay.
Posted May 05, 2022 - 16:13 CDT
Monitoring
The queues are returning to normal. We are continuing to monitor.
Posted May 05, 2022 - 14:10 CDT
Investigating
We are currently investigating this issue.
Posted May 05, 2022 - 13:32 CDT
This incident affected: Hosted Spam & Virus Filtering.