Email Delivery Delays

Incident Report for EMPIST

Resolved

All queued email has been delivered and services are operational.
Posted Oct 20, 2025 - 18:39 CDT

Update

We are seeing significant progress as services in the US-EAST-1 (N. Virginia) region continue to recover. Our teams are actively ensuring that all queued emails are being released and that normal mail flow is fully restored.
Posted Oct 20, 2025 - 17:36 CDT

Update

AWS has reported continued progress in restoring affected services, and we are seeing steady improvement with emails being delivered.
Posted Oct 20, 2025 - 14:18 CDT

Monitoring

It appears that email delivery is slowly being restored, and any queued messages are being sent out. It may take time to fully catch up.
Posted Oct 20, 2025 - 13:10 CDT

Update

AWS is in the process of resolving the service disruption. You can stay informed by visiting https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:39 CDT

Identified

We are currently experiencing delays with incoming and outgoing email due to an ongoing AWS outage. Internal email should continue to function normally. All delayed messages will be automatically delivered once the issue is resolved.

For real-time updates on the AWS outage, please visit https://health.aws.amazon.com/health/status

PLEASE NOTE: You may also be experiencing issues with other AWS dependent services.
Posted Oct 20, 2025 - 08:03 CDT
This incident affected: Email Security / Deliverability.