Cloudflare Global Network experiencing issues

Incident Report for EMPIST

Resolved

All Cloudflare services have been fully restored and platforms are fully operational.
Posted Nov 18, 2025 - 09:53 CST

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 09:29 CST

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 07:57 CST

Monitoring

Due to the Cloudflare outage, we are experiencing sporadic issues with Deskware. Our team is actively monitoring the situation and reviewing the Cloudflare status page for updates. You can also follow Cloudflare’s status page for additional information: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 06:00 CST
This incident affected: Monitoring Platform (MSP), EMPIST 360, and Deskware.